> var selObj = app.activeDocument.selection;
> var graphicLineCount = 0 ;
> for (var j = 0 ; j < selObj.length ; j++) {
> if (selObj[j].constructor.name =="GraphicLine") {
> graphicLineCount ++ ;
> for (var h = 0 ; h < selObj[j].graphicLines.length ; h ++) {
> selObj[j].graphicLines[h].strokeWeight = 0.1 ;
> }
> }
> }
> alert("選択していた " + selObj.length + " つのうちの " + graphicLineCount+ " つの罫線を0.1mmにしました")
selObj[j]が"GraphicLine"なんですから、
selObj[j].graphicLines[h]ってのはおかしいんでないですか
[13828] (z-) (2012/04/05 Thu 14:15) web